Railway - GitHub operations are being rate-limited. Users may be unable to log-in or add GitHub repos. We are working on resolution for this issue. – Incident details

GitHub operations are being rate-limited. Users may be unable to log-in or add GitHub repos. We are working on resolution for this issue.

Resolved
Degraded performance
Started about 17 hours agoLasted about 4 hours

Affected

External / Third-Party Integrations

Degraded performance from 3:06 PM to 3:25 PM, Under maintenance from 3:25 PM to 5:38 PM, Degraded performance from 5:38 PM to 6:13 PM, Operational from 6:13 PM to 7:15 PM

GitHub

Degraded performance from 3:06 PM to 3:25 PM, Under maintenance from 3:25 PM to 5:38 PM, Degraded performance from 5:38 PM to 6:13 PM, Operational from 6:13 PM to 7:15 PM

Updates
  • Resolved
    Resolved
    Our monitors have shown that we have good effect on our changes, although we have improvement, we are still monitoring the impact for all customers.
  • Monitoring
    Monitoring
    We have observed no further GitHub rate limiting in the last 60 minutes and we are reanbling GitHub authentication.
  • Update
    Update
    We have rolled out additional fixes to improve GitHub callpath resiliency. We are monitoring their effectiveness and will issue an update once we finish monitoring.
  • Identified
    Identified
    We have disabled GitHub log in to reduce rate-limit pressure on the system.
  • Investigating
    Investigating
    GitHub operations are being rate-limited. Users may be unable to log-in or add GitHub repos. We are working on resolution for this issue.