Railway - Small % of Project 404's – Incident details

Small % of Project 404's

Resolved
Operational
Started 3 days agoLasted 5 minutes

Affected

Dashboard

Partial outage from 7:35 PM to 7:40 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We rolled out a change where we dropped a column unsafely. While the new deploy was rolling out (~5 minutes), old deploys, the ORM we used automatically queried the old field. As a result, some small % of users who hard refreshed (and had to load project state) may have seen a 404 briefly.

    We're rolling out a lint rule to catch this in the future. Apologies