Railway - Edge Proxy outage – Incident details

US West (us-west1 / Oregon, USA) experiencing degraded performance

Edge Proxy outage

Resolved
Major outage
Started 18 days agoLasted about 1 hour

Affected

Edge Network

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:34 PM, Operational from 10:32 PM to 10:34 PM, Degraded performance from 10:34 PM to 10:37 PM, Operational from 10:34 PM to 10:40 PM

US West (us-west1 / Oregon, USA)

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:37 PM, Operational from 10:37 PM to 10:40 PM

US East (us-east4 / Virginia, USA)

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:34 PM, Operational from 10:34 PM to 10:40 PM

EU West (europe-west4 / Amsterdam, Netherlands)

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:34 PM, Operational from 10:34 PM to 10:40 PM

Southeast Asia (asia-southeast1 / Singapore)

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:32 PM, Operational from 10:32 PM to 10:40 PM

TCP Proxy

Major outage from 9:13 PM to 10:17 PM, Degraded performance from 10:17 PM to 10:37 PM, Operational from 10:37 PM to 10:40 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Update

    All proxies are back up in all regions. We are still monitoring as everything is coming back up.

  • Monitoring
    Update

    Europe and US-East proxies are back up

  • Monitoring
    Update

    Southeast Asia (Singapore) is back up

  • Monitoring
    Monitoring

    Most of the traffic appears to be back up, but we're still monitoring.

  • Identified
    Update

    Our fix is rolling out and we are seeing recovery for some customers.

  • Identified
    Identified

    Our new edge proxy is experiencing a major outage. We have identified the issue and are working on a fix