Railway - Dashboard may be slow or failing to load for some users – Incident details

Dashboard may be slow or failing to load for some users

Resolved
Degraded performance
Started 4 months agoLasted 21 minutes

Affected

Dashboard

Degraded performance from 1:17 PM to 1:21 PM, Operational from 1:21 PM to 1:38 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Our database was temporarily unreachable from a subset of our API backend hosts, resulting in slower load times and errors for some users. We have performed a rolling restart of those hosts and are seeing full recovery.

  • Monitoring
    Monitoring

    We have implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating
    We are currently investigating this incident.