Railway - GitHub API Rate Limits – Incident details

GitHub API Rate Limits

Resolved
Degraded performance
Started over 1 year agoLasted 7 minutes

Affected

Builds

Degraded performance from 3:12 PM to 3:18 PM

Builders

Degraded performance from 3:12 PM to 3:18 PM

Updates
  • Resolved
    Resolved

    Builds are now successfully deploying.

  • Identified
    Identified

    API issues meant that builds were stuck in queue. Resuming the queue overloaded the requests sent to GH to trigger new builds.

  • Investigating
    Investigating

    GitHub API Rate Limits