Railway - Slow Builds/Deploys – Incident details

Slow Builds/Deploys

Resolved
Degraded performance
Started 1 day agoLasted about 2 hours

Affected

Builds (Railway Metal)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

Image Registry (Metal)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

Build Machines (Metal)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

Deployments (Railway Metal)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

US West (Metal / California, USA)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

US East (Metal / Virginia, USA)

Degraded performance from 3:53 PM to 5:48 PM, Operational from 5:48 PM to 6:20 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We are almost done catching up with the backlog and have re-enabled non-pro deploys.

  • Monitoring
    Monitoring

    Builds and deploys are taking longer than usual as github resumes webhooks after their outage.

    We are pausing Hobby deployments until the system catches up with the buildup of new deploys