Railway-hosted applications may be inaccessible for users connecting from Europe

Resolved
Operational
Started 3 months ago Lasted about 6 hours

Affected

Edge Network
Updates
  • Resolved
    Resolved
    Our mitigation efforts were successful and services have been restored for all users. We will publish a write-up of this incident shortly.
  • Monitoring
    Monitoring
    We have successfully rolled out a mitigation and are seeing service recovery for most users. We're continuing to monitor the situation and are working towards restoring services for all users.
  • Identified
    Update
    We are continuing to work on mitigating this attack.
  • Identified
    Update
    We are continuing to work on mitigating this attack.
  • Identified
    Update
    We apologize for the downtime and inconvenience this has caused. We are currently tweaking our mitigation strategies and will continue rolling out gradual service restoration to all impacted users.
  • Identified
    Update
    We're continuing to work on mitigating the DDoS attack. We have identified a potential mitigation strategy and will attempt rolling it out shortly.
  • Identified
    Identified
    We've identified a DDoS attack on our EU edge proxy hosts. We are working on mitigating and restoring service for all impacted users.
  • Investigating
    Investigating

    We rolled out a temporary fix that did not work. We are in the process of bringing our EU edge proxy hosts back online for further investigations. This incident only applies to a subset of requests originating from or routed through the EU. Applications are still serving fine globally.

  • Monitoring
    Monitoring
    NOTE: This only applies to a subset of requests originating from the EU. Applicaions are still serving fine globally. We've also rolled out a fix and requests are going through again
  • Investigating
    Investigating

    Our EU edge proxy is partially down. Railway-hosted applications may be inaccessible for users connecting from EU during this time.