Resolved
Dashboard is not loading

Started
June 28, 2022 at 3:08 PM
Status
Resolved after 7 minutes
Affected
Dashboard

Impact

Partial outage
  • Resolved
    June 28, 2022 at 3:15 PM

    The issue is resolved

  • Investigating
    June 28, 2022 at 3:08 PM

    We're currently investigating an issue.